1KZ-TE TIMING ISSUE??

For all Toyota related topics ie. Hilux, Cruiser topics

1KZ-TE TIMING ISSUE??

Postby pradon35s » Wed Nov 04, 2009 10:47 am

HI
I HAVE A 93 KZJ78 PRADO WITH THE 1KZ-TE MOTOR.
IT HAS AN INTERMITTANT ISSUE WHERE IT IS DRIVING FINE AND THEN IF I STOP AT LIGHTS AND IT IS IDLING FOR MORE THAN SAY A MINUTE IT STARTS TO KNOCK, ALMOST LIKE A BOTTOM END BLOWEN KNOCK BUT HAVE BEEN TOLD ITS THE INJECTION TIMING, ALSO THE CHECK ENGINE LIGHT COMES ON. BUT THEN IF U TAKE OFF AS SOON AS ITS UNDER LOAD ITS OK.
THERE IS A SENOR ON THE INTAKE SIDE OF THE BLOCK, DOWN THE BOTTOM NEAR THE TRANSMISSION, 2 PIN PLUG, IM GUESSING A KNOCK SENSOR? THIS PULG WAS BROKEN AND IS WAT STARTED THE ISSUE I THINK, I HAVE SINCE REPLACED THIS SENSOR AND THE PLUG THAT GOES ON IT BUT STILL NO CHANGE.

ANY HELP WOULD BE MINT

CHEERS
User avatar
pradon35s
Hard Yaka
 
Posts: 212
Joined: Mon Oct 12, 2009 3:49 pm

Re: 1KZ-TE TIMING ISSUE??

Postby 4WDbits » Wed Nov 04, 2009 11:40 am

The timing is computer controlled (can't remember the exact terminology in the wiring diagram).
User avatar
4WDbits
Hard Yaka
 
Posts: 641
Joined: Thu Oct 27, 2005 1:00 pm
Location: Auckland

Re: 1KZ-TE TIMING ISSUE??

Postby Landy Rover » Wed Nov 04, 2009 3:59 pm

Really should go to garage with scanner to check the fault codes that will be stored as a result of the check engine light going on. It could be many things wrong, eg temp sensor, MAP sensor, TP sensor, even injection pump. Save yourself the headache of replacing stuff that doesnt need to be :) :)
S3 Rover truck cab, injected 186, Sals rear,Toyota P/steer, Safari disc brakes front, R/Rover D/brakes rear, 9500 winch,twin optima batts, roll bar, Disco seats, 33" JTs, scene lamps, onboard air, Front ARB locker.
User avatar
Landy Rover
Hard Yaka
 
Posts: 263
Joined: Fri Dec 12, 2008 1:11 pm
Location: Feilding

Re: 1KZ-TE TIMING ISSUE??

Postby pradon35s » Thu Nov 05, 2009 9:53 am

awsome,

cheers for ur help guys i had no idea they could be scanned il go get that done today!!

thanks for ur help!

forum once again saves me $100s.....
User avatar
pradon35s
Hard Yaka
 
Posts: 212
Joined: Mon Oct 12, 2009 3:49 pm

Re: 1KZ-TE TIMING ISSUE??

Postby UBZ » Thu Nov 05, 2009 7:23 pm

their should be a mark on the block near the front of the fuel pump that the pump lines up to initially set the fuel timing from factory.

does the engine warning light come on and stay on when you start the truck?

has the battery been disconnected since the sensor was damaged.
Disconnecting the battery will clear the fault codes in the ECU.

Pretty sure it is the crank position sensor down the bottom. Was it replaced with a Toyota Genuine Part.
LJ50 / LJ80Q / D110
Chris.
User avatar
UBZ
Hard Yaka
 
Posts: 1540
Joined: Sat Aug 19, 2006 1:00 pm
Location: West Side

Re: 1KZ-TE TIMING ISSUE??

Postby 1rugger » Fri Nov 06, 2009 10:11 am

there will also be two wires in the diagnostic plug you can short out and read the faults you're self if you can get you're hands on a manual for the truck it will tell you how to do it and what the codes (flashes of check eng light) correspond to.
89 LN106 Hilux 3.0L turbo,2" bodylift 50mm suspension lift, lockrite rear, lsd front & 33" wranglers & winch
User avatar
1rugger
Hard Yaka
 
Posts: 171
Joined: Tue Sep 12, 2006 1:00 pm
Location: Christchurch

Re: 1KZ-TE TIMING ISSUE??

Postby Jerry » Fri Nov 06, 2009 4:13 pm

I've got a downloaded toyota manual if you need it, it lists the diagnostic functions as well as where all the sensor thingys are..... its only 14mb (can try and email if you arent on dial up etc)
KZJ71 & KZJ78
User avatar
Jerry
Yes Dear
 
Posts: 8216
Joined: Tue May 30, 2006 1:00 pm
Location: Wellington 027 479 2417

Re: 1KZ-TE TIMING ISSUE??

Postby pradon35s » Sat Nov 07, 2009 4:42 pm

yes i heard bout the flash codes, iv tried getting my hands on a manual but every1 seems to say they dont exsist for these??

engine check light comes on when timing goes out and knocking starts but it is intermittant but kinda getting worse.

jerry, if u could email me the manual that would be awsome?

adam.lange@live.com
User avatar
pradon35s
Hard Yaka
 
Posts: 212
Joined: Mon Oct 12, 2009 3:49 pm

Re: 1KZ-TE TIMING ISSUE??

Postby tallsam66 » Sat Nov 07, 2009 6:07 pm

You can diagnose the fault codes yourself....its very easy.
Go to the following website & check it out.

http://www.ncttora.com/fsm/1KZ-TE%20Engine%20Manual/hilux/info/manuals/1KZ-TE/index.html

Basically get a small piece of wire & with the key turned off connect terminals TE1 & E1 together.
Then turn on the key...the check engine light will flash & tell the the error codes.
User avatar
tallsam66
Hard Yaka
 
Posts: 1815
Joined: Sat Jul 01, 2006 1:00 pm
Location: Christchurch

Re: 1KZ-TE TIMING ISSUE??

Postby pradon35s » Wed Nov 25, 2009 6:07 pm

i went through the manual understanding it as best i could..
bridged the terminals and took fault codes from ecu..

gave me flash codes..

one flash, two flashes.. code 12 im guessing??

Engine Speed Sensor.. which is the sensor that i thought was knock sensor.
i have since replaced the sensor and there was dodgey loom going to it so replaced the plug and wiring.
started it up. still no change..

disconnected battery for 10min to reset codes??

still no change, noise is now worse, timing seems to be out as soon as i start it up and stays out is not intermittant anymore..

im stumped for ideas....
ECU??
User avatar
pradon35s
Hard Yaka
 
Posts: 212
Joined: Mon Oct 12, 2009 3:49 pm

Re: 1KZ-TE TIMING ISSUE??

Postby UBZ » Wed Nov 25, 2009 6:32 pm

First thoughts that come to mind.

jumped a tooth on the timing belt?
or injector pump has moved position in relation to the block.
or the wiring fault is further up the loom , have you done a continuity check from the sensor back to the ECU?
LJ50 / LJ80Q / D110
Chris.
User avatar
UBZ
Hard Yaka
 
Posts: 1540
Joined: Sat Aug 19, 2006 1:00 pm
Location: West Side


Return to Toyota

Who is online

Users browsing this forum: No registered users and 2 guests