G16B idle issue - un burn fuel smell

User avatar
samurai
Bush Crasher
Posts: 60
Joined: Thu Dec 19, 2013 10:39 am

G16B idle issue - un burn fuel smell

Postby samurai » Tue Apr 16, 2019 9:52 am

Hi all,

Please help!

Over the weekend I took the truck out and let it run about 10min and then took it for a drive. The truck had no issues at all but it was low on fuel but light wasn't indicating.

I took the car for a 10km drive on the motorway and it was all ok up until I came home and put to P. Car start stalling and it sounded like it's running on 3 cylinders.

But when I rev the engine it revs fine between 1000 - 3000RPM range and no stall or miss fire at all. as soon as release the paddle it is the same again.

No check engine light
takes time to start


What would be the cause? what should i check?

regards,
JC

stealth
Hard Yaka
Posts: 154
Joined: Sat Jan 15, 2011 10:18 am
Location: Dunedin

Re: G16B idle issue - un burn fuel smell

Postby stealth » Tue Apr 16, 2019 12:15 pm

I would start buy pulling leads off and seeing which one doesn't affect its running on 3, then checking that lead and plug, can swap the lead or plug to see if the issue is the same. could also be a dizzy if it has one or a coilpack/igniter.

Im not too familiar with this motor but in general the above might ID it.

User avatar
samurai
Bush Crasher
Posts: 60
Joined: Thu Dec 19, 2013 10:39 am

Re: G16B idle issue - un burn fuel smell

Postby samurai » Tue Apr 16, 2019 12:25 pm

stealth wrote:I would start buy pulling leads off and seeing which one doesn't affect its running on 3, then checking that lead and plug, can swap the lead or plug to see if the issue is the same. could also be a dizzy if it has one or a coilpack/igniter.

Im not too familiar with this motor but in general the above might ID it.



Thank you for that and i am planning to start the same way, already checked for 4 plugs (BKR6E) what i am not able to understand engine runs well on high rpm and the idle is the issue.

User avatar
samurai
Bush Crasher
Posts: 60
Joined: Thu Dec 19, 2013 10:39 am

Re: G16B idle issue - un burn fuel smell

Postby samurai » Wed Apr 17, 2019 6:42 pm

I have changed the spark plugs and the plug leads but issue still the same, reluctant to idle but smooth in high RPM's (from about 1000RPM)

User avatar
kbushnz
Hard Yaka
Posts: 2485
Joined: Wed Sep 16, 2009 9:03 am
Location: Massey, Auckland

Re: G16B idle issue - un burn fuel smell

Postby kbushnz » Thu Apr 18, 2019 7:51 am

Have a read thru this site....
http://www.fixkick.com/
Could be a few things but pretty much everything that it could be is on this guys site.
Cheers Calvin
KZJ78 Landcruiser Prado...

User avatar
samurai
Bush Crasher
Posts: 60
Joined: Thu Dec 19, 2013 10:39 am

Re: G16B idle issue - un burn fuel smell

Postby samurai » Thu Apr 18, 2019 11:10 am

kbushnz wrote:Have a read thru this site....
http://www.fixkick.com/
Could be a few things but pretty much everything that it could be is on this guys site.



Thank you Mate

User avatar
samurai
Bush Crasher
Posts: 60
Joined: Thu Dec 19, 2013 10:39 am

Re: G16B idle issue - un burn fuel smell

Postby samurai » Fri Apr 19, 2019 7:08 pm

Thank you all, issue resolved!!

Just a carb cleaner to the throttle body resolve the issue and idle is steady as. :D

regards,
JC

Return to “Suzuki”

Who is online

Users browsing this forum: Google [Bot] and 1 guest