4JG2 no start.

User avatar
nivaman
Hard Yaka
Posts: 243
Joined: Mon Jul 10, 2006 12:00 pm

4JG2 no start.

Postby nivaman » Sat Jan 07, 2017 3:26 pm

Flattened the battery trying to start the engine, tried a spare on the off chance it had enough charge but it didn't so tried a known good battery and the engine started but it now fails to start. Have fitted good 2nd hand glow plugs (3 originals were knackered), checked voltage at the glow plug rail, checked fuses/relays etc, 2nd hand glow plug relay tried with no success. Stop solenoid clicks when 12v power is applied direct from the battery. Fuel filter primer pumps up firm, the engine started when I applied direct 12v to the glow plug rail and I tried it again when the engine was cold but it failed to start.
Fuel filter was replaced within the last 6 months, battery is fully charged.
Is there anything I have missed or could try to get the engine started?.
Cheers.

User avatar
Crash bandicoot
Hard Yaka
Posts: 2881
Joined: Thu Dec 30, 2010 7:19 pm
Location: Towing a hilux

Re: 4JG2 no start.

Postby Crash bandicoot » Sat Jan 07, 2017 4:24 pm

Take the intercooler pipe off and squirt crc or the like down its throat whilst cranking. If it runs its defo' glow plug issue.

Just depends on if it's the busbar or a crook glow plug relay or glow plug timer.

Another thing to google is " isuzu hard to start injector pump seal." But that isnt hard to fix if ya dont mind spinning spanners.
Waiter...there is a drought in my glass.

Pj_Marsh
Hard Yaka
Posts: 193
Joined: Mon Feb 20, 2012 5:46 pm

Re: 4JG2 no start.

Postby Pj_Marsh » Sat Jan 07, 2017 6:00 pm

There's a set of vacuum pipes near the diesel filter that I knocked off once, wouldn't start until I found them

User avatar
nivaman
Hard Yaka
Posts: 243
Joined: Mon Jul 10, 2006 12:00 pm

Re: 4JG2 no start.

Postby nivaman » Mon Jan 09, 2017 6:09 pm

Hmm, interesting developments.
So I charged the battery and refitted it, run a wire from the positive battery post to the stop solenoid on the fuel pump which clicked.
I left the wire on it and turned the key in the ignition......the engine fired into life.
I then pulled the wire and the engine died, I then reconnected the stop solenoid and turned the key in the ignition.....the engine fired into life.
Took the vehicle for a good run and left it to cool down overnight and it started right up in the morning and has been starting and shutting down as normal.
Is the stop solenoid sticking or should I replace it?, is the solenoid even at fault or is there something else wrong?.

User avatar
Crash bandicoot
Hard Yaka
Posts: 2881
Joined: Thu Dec 30, 2010 7:19 pm
Location: Towing a hilux

Re: 4JG2 no start.

Postby Crash bandicoot » Mon Jan 09, 2017 7:02 pm

If it's starts fine with a hotwire direct from the battery then just find another source of ignition feed for the stop solenoid.
Waiter...there is a drought in my glass.

User avatar
nivaman
Hard Yaka
Posts: 243
Joined: Mon Jul 10, 2006 12:00 pm

Re: 4JG2 no start.

Postby nivaman » Tue Jan 10, 2017 8:20 am

Crash bandicoot wrote:If it's starts fine with a hotwire direct from the battery then just find another source of ignition feed for the stop solenoid.

Interesting thing is it now starts and runs normally, no hotwires needed. Makes me think the stop solenoid
is sticky?.

Pj_Marsh
Hard Yaka
Posts: 193
Joined: Mon Feb 20, 2012 5:46 pm

Re: 4JG2 no start.

Postby Pj_Marsh » Tue Jan 10, 2017 12:25 pm

Is this out of a 90's vintage auto bighorn?

Return to “Isuzu”

Who is online

Users browsing this forum: No registered users and 2 guests