TD42 missing at 1800 rpm

Moderator: Mark

webfish
Driver/Navigator
Posts: 25
Joined: Tue Feb 09, 2010 10:13 am

TD42 missing at 1800 rpm

Postby webfish » Sat Jul 18, 2020 11:56 am

Long time since I was last here.

My 1990 Safari TD42 has suddenly started missing at 1800rpm. I though it was probably the fuel filter so changed that but alas, no better.

Basically, runs fine until you hit that rev range then there is a sudden loss of power and the vehicle simply won't push through. If I back off a bit she drives fine.

Any ideas before I take it to the garage?

MihiT
Hard Yaka
Posts: 340
Joined: Sun Feb 08, 2015 12:33 pm
Location: RD8

Re: TD42 missing at 1800 rpm

Postby MihiT » Sun Jul 19, 2020 9:41 am

If it's auto, I blame the box.

If not. How many KM since: Air cleaner? Injectors?
Check rubber lines/connections for vacuum leaks
There's also a secondary gauze filter atop the IP. Remove and clean.
- 1990 LWB Safari flatdeck, TD42 -

webfish
Driver/Navigator
Posts: 25
Joined: Tue Feb 09, 2010 10:13 am

Re: TD42 missing at 1800 rpm

Postby webfish » Sun Jul 19, 2020 9:59 am

Thanks, vehicle is manual and must be about 350K on the clock.

Haven't done the air-cleaner in a couple of years but she's had pretty light use due to company ute. Might be worth replacing anyway.

What's the IP? Once this gets too technical I need to seek professional help but it's worth trying a few obvious things first :D

webfish
Driver/Navigator
Posts: 25
Joined: Tue Feb 09, 2010 10:13 am

Re: TD42 missing at 1800 rpm

Postby webfish » Sun Jul 19, 2020 3:27 pm

FFS. Changed the air-filter and it runs sweet.

Thanks @MihiT

MihiT
Hard Yaka
Posts: 340
Joined: Sun Feb 08, 2015 12:33 pm
Location: RD8

Re: TD42 missing at 1800 rpm

Postby MihiT » Thu Jul 23, 2020 6:03 pm

webfish wrote:What's the IP? Once this gets too technical I need to seek professional help but it's worth trying a few obvious things first :D


Injector pump. Is one banjo bolt on the fuel feed into it, spring and mesh filter underneath. Easy enough to get to. Need fairly fine hook/pick to pull the screen out.

Simple things often overlooked, glad it was an easy fix!
- 1990 LWB Safari flatdeck, TD42 -

MihiT
Hard Yaka
Posts: 340
Joined: Sun Feb 08, 2015 12:33 pm
Location: RD8

Re: TD42 missing at 1800 rpm

Postby MihiT » Thu Jul 23, 2020 6:06 pm

FWIW I run a K&N washable/oiled filter in mine. Spend a lot of time on gravel, and manage to pick up all kinds of road grime sludgy crap as well. When performance (such as it is :P ) drops off I generally give it oil and filters.
- 1990 LWB Safari flatdeck, TD42 -

Return to “Nissan”

Who is online

Users browsing this forum: No registered users and 4 guests