97 Terrano Reverse Lights Not Going

Moderator: Mark

tuckertrucker
Hard Yaka
Posts: 161
Joined: Tue Sep 01, 2015 10:59 pm
Location: Kerikeri

97 Terrano Reverse Lights Not Going

Postby tuckertrucker » Tue Sep 15, 2020 7:05 pm

Got a 97 Terrano, reverse lights don't come on when reverse is engaged.

Can't find a blown fuse, or even a fuse labelled rev lts for that matter. Bulbs are fine.

Where abouts on the trans is the switch? Are they a common failure point?

cheers all

User avatar
coxsy
Hard Yaka
Posts: 5186
Joined: Tue Jun 20, 2006 12:00 pm
Location: mangere auckland
Contact:

Re: 97 Terrano Reverse Lights Not Going

Postby coxsy » Sat Sep 26, 2020 8:56 pm

Think there is an loam off the trans that hooks to sensor check that out , it was what was wrong with my saf
89 safari, pto winch, 33x15 simexs. sliders,75mm lift . turbo intercoolered

User avatar
Ant
Hard Yaka
Posts: 281
Joined: Wed Feb 08, 2012 9:44 am
Location: Auckland, East
Contact:

Re: 97 Terrano Reverse Lights Not Going

Postby Ant » Mon Sep 28, 2020 6:41 am

Not sure if its the same as the Safari ones. but my safari had the same issue, the switch is on the very top of the trans and is almost impossible to get to. I was just able to disconnect the wire and test the switch but did not have enough space to remove the switch to repair it without dropping the transmission.
92 LWB Safari TD42
95 4.5L Cruiser, AKA "Thirsty"

Return to “Nissan”

Who is online

Users browsing this forum: No registered users and 3 guests